Errores con Python 3.X al utilizar Geany en Mac en IOTeca

Errores con Python 3.X al utilizar Geany en Mac

Usuarios de Mac que utilizan el IDE Geany(www.geany.org) informan de problemas al querer ejecutar un script.

El algunas versiones del sistema operativo de Mac viene preinstalado el interprete de python 2.7.

Una forma rápida de probar la versión del interprete que estamos utilizando es realizar un print con la sintáxis anterior.

print "prueba"

Si lo ejecuta correctamente se está utilizando la versión 2.7, si da error de sintáxis por no contar con los paréntesis se esta utilzando 3.5.X+.

Para indicarle a Geany la versión que debe utilizar se debe ingresar al menú Construir, y luego Establecer comando de construcción.

En esta pantalla se debe colocar un 3 detrás de donde dice python en los campos Compile y Execute, como se muestra:


Si utiliza otro sistemas operativo donde también tenga instaladas ambas versiones del interprete, también deberá realizar las mismas acciones para poder utilizar el IDE Geany con la versión 3.5.X+.

Creado: 17/07/2020  

Publicidad

| Volver a Python |

Comentarios

Para poder comentar debés registrarte e ingresar al sitio.